Degraded performance

Incident Report for Maxem

Resolved

This incident has been resolved.
Posted Nov 26, 2025 - 13:38 CET

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 26, 2025 - 12:34 CET

Investigating

We're experiencing a degraded performance of our platform and are currently looking into the issue.
Posted Nov 26, 2025 - 12:28 CET
This incident affected: Maxem Energy Cloud (Management portal, Maxem API).